Guidewire Cloud Platform Status
Check here for service availability updates on Guidewire Cloud Platform (GWCP).

Subscribe to get real-time updates via email, RSS, Slack and more. You can also request support or report a missing incident via https://community.guidewire.com
NPE Service Interruption Affecting Multiple NPE Customers in AMER
Incident Report for Guidewire
Postmortem

Please refer to the Knowledge Article via this link for more information.

Posted Nov 14, 2023 - 12:47 UTC

Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 19:00 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 12, 2023 - 14:47 UTC
Monitoring
Secrets fetching has gone below the threshold but we urge all customers to apply the fix immediately. The earlier you implement it, the more effective it will be in reducing the unwanted calls to fetch secrets.

Please refer to the Tech Bulletin Board for further detailed information: https://community.guidewire.com/s/article/Guidewire-CredentialsPlugin-Fix-for-Credentials-Lookup-Failures
Posted Nov 10, 2023 - 16:32 UTC
Update
On October 27th, we released a patch (1.3.2) to address an issue with the application making excessive calls to AWS to retrieve secrets. Guidewire has developed a fix to improve the performance of the secret fetching actions and reduce the number of unwanted calls. The patch has been pushed to your bitbucket, and we urge all customers to implement it in their code base immediately. The earlier you implement it, the more effective it will be in reducing the unwanted calls to fetch secrets.
Posted Nov 10, 2023 - 14:53 UTC
Identified
We recently released a patch on October 27th to address an issue where the application made excessive calls to AWS to retrieve secrets. Guidewire has developed a fix to improve the performance of the secret fetching actions and reduce the number of unwanted calls. We ask all customers to implement this fix in your code base immediately. The earlier you implement it, the more effective it will be in reducing the unwanted calls to fetch secrets.
Posted Nov 10, 2023 - 13:48 UTC
Investigating
Guidewire Support is aware of an issue with Non-Production Environments that is causing interruptions due to secrets. All necessary resources are engaged to restore this service as quickly as possible. We will post regular updates on our progress.
Posted Nov 10, 2023 - 12:55 UTC
This incident affected: INSURANCESUITE NON PRODUCTION ENVIRONMENTS (USA, CANADA).