Guidewire Cloud Platform Status
Check here for service availability updates on Guidewire Cloud Platform (GWCP). For ProNavigator status, please visit https://status.pronavigator.ai/

Subscribe to get real-time updates via email, RSS, Slack and more. You can also request support or report a missing incident via https://community.guidewire.com

TeamCity Build Service Interruption in Non-Production for Integration Gateway Apps Impacting Multiple Customers Across All Regions

Incident Report for Guidewire

Resolved

Guidewire has published a patch to improve the reliability of Integration Gateway TeamCity builds by routing Maven Central dependency downloads through the Guidewire BinRepo Maven Central mirror.

Customers should apply the patch to their IG App on the corresponding release versions. For detailed release notes and patch installation instructions, refer to article 000047237 (https://community.guidewire.com/s/article/Improved-Integration-Gateway-application-builds-reliability-for-Maven-dependency-downloads)
Posted Jul 31, 2026 - 15:04 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 30, 2026 - 19:02 UTC

Update

Guidewire Support is actively pursuing a permanent solution, which will involve caching packages directly within the GWCP ecosystem.

We have confirmed that upstream rate-limiting has now completely subsided and rate-limiting errors are not happening when building IG apps in TeamCity. If customers continue to experience issues please raise a community case.
Posted Jul 30, 2026 - 14:45 UTC

Update

Guidewire Support is actively pursuing a permanent solution, which will involve caching packages directly within the GWCP ecosystem. We are still working on providing this permanent fix and we will provide an update within the next 24 hours.

We have confirmed that upstream rate-limiting has temporarily subsided due to decreased usage. However, customers continuing to experience issues should still follow the temporary workaround steps available at article 000047213 (https://community.guidewire.com/s/article/Temporary-solutions-for-the-customers-to-connect-to-mirrored-Maven-Central-repo).
Posted Jul 29, 2026 - 14:44 UTC

Update

Guidewire Support is actively pursuing a permanent solution, which will involve caching packages directly within the GWCP ecosystem. We remain on track to deliver this fix within 24 hours of the incident start, with targeted completion by 9:00 AM PDT on July 29, 2026.

We have confirmed that upstream rate-limiting has temporarily subsided due to decreased usage. However, customers continuing to experience issues should still follow the temporary workaround steps available at article 000047213. Our next update will be provided by 9:00 AM PDT on July 29, 2026.
Posted Jul 29, 2026 - 05:06 UTC

Monitoring

Detailed steps for connecting to the mirrored Maven URL are available at 000047213 (https://community.guidewire.com/s/article/Temporary-solutions-for-the-customers-to-connect-to-mirrored-Maven-Central-repo). Customers should update the relevant files and rerun their builds. Guidewire teams are actively working on a permanent solution and will provide an update as soon as it is available (approximately 07/28/2026 10 PM PDT ).
Posted Jul 28, 2026 - 17:52 UTC

Update

Guidewire Support is still finalizing the step-by-step instructions for connecting to the Maven mirrored URL and will share an update shortly. In the meantime, we continue to advise customers to be mindful of retries, as repeated attempts may have adverse effects.
Posted Jul 28, 2026 - 17:16 UTC

Update

Guidewire Support has identified the root cause of this incident (rate limiting on the Maven URL) and is actively working on a permanent solution. In parallel, we are preparing a temporary solution that will allow customers to use a mirrored Maven Central repository, and we will share step-by-step instructions for using the mirrored URL shortly. Guidewire's permanent fix may take up to 24 hours to implement. In the meantime, we advise customers to be mindful of retries, as repeated attempts may have adverse effects.
Posted Jul 28, 2026 - 16:44 UTC

Update

Guidewire Support has identified the cause of this incident and is working to determine the appropriate solution. All necessary teams are engaged to restore service as quickly as possible, and we will provide regular updates on our progress.
Posted Jul 28, 2026 - 16:07 UTC

Update

Guidewire Support has identified the cause of this incident and is working to determine the appropriate solution. All necessary teams are engaged to restore service as quickly as possible, and we will provide regular updates on our progress.
Posted Jul 28, 2026 - 15:32 UTC

Identified

Guidewire Support has identified the cause of this incident, which is impacting TeamCity Builds in Non-Production Environments for Integration Gateway Apps. Please use the following workaround: Re-trigger the build after 1 hour. We will post regular updates on our progress.
Posted Jul 28, 2026 - 14:17 UTC

Investigating

Guidewire Support is aware of an issue with intermittent TeamCity Build failures in the non-production environment for Integration Gateway Apps. Please use the following workaround: Re-trigger the build after 1 hour. All necessary resources are engaged to restore this service as quickly as possible. We will post regular updates on our progress.
Posted Jul 28, 2026 - 13:48 UTC
This incident affected: GUIDEWIRE HOME (GWH) (Montréal, N. Virginia, Paris, Sydney, Tokyo, Zurich).